What’s Vulnerable › Vulnerabilities
CVE-2025-46776
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-18 · updated 2026-10-18
- Weakness: CWE-120
Description
A buffer copy without checking size of input ('classic buffer overflow') vulnerability in Fortinet FortiExtender 7.6.0 through 7.6.1, FortiExtender 7.4.0 through 7.4.6, FortiExtender 7.2 all versions, FortiExtender 7.0 all versions may allow an authenticated user to execute arbitrary code or commands via crafted CLI commands.
Affected products
- Fortinet FortiExtender: from 7.0.0 before 7.4.8; from 7.6.0 before 7.6.3 — fixed in 7.4.8, 7.6.3
How to fix
Upgrade to a fixed version: Fortinet FortiExtender 7.4.8, 7.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-46776 or the next vulnerability affects your stack