What’s Vulnerable › Vulnerabilities
CVE-2025-46813: Private data leak on login-required Discourse sites
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-05 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open-source community platform. A data leak vulnerability affects sites deployed between commits 10df7fdee060d44accdee7679d66d778d1136510 and 82d84af6b0efbd9fa2aeec3e91ce7be1a768511b. On login-required sites, the leak meant that some content on the site's homepage could be visible to unauthenticated users. Only login-required sites that got deployed during this timeframe are affected, roughly between April 30 2025 noon EDT and May 2 2025, noon EDT. Sites on the stable branch are unaffected. Private content on an instance's homepage could be visible to unauthenticated users on login-required sites. Versions of 3.5.0.beta4 after commit 82d84af6b0efbd9fa2aeec3e91ce7be1a768511b are not vulnerable to the issue. No workarounds are available. Sites must upgrade to a non-vulnerable version of Discourse.
Affected products
- discourse: before 3.5.0; 3.5.0-beta1, 3.5.0-beta2, 3.5.0-beta3 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: discourse 3.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/10df7fdee060d44accdee7679d66d778d1136510
- https://github.com/discourse/discourse/commit/82d84af6b0efbd9fa2aeec3e91ce7be1a768511b
- https://github.com/discourse/discourse/security/advisories/GHSA-v3h7-c287-pfg9
Get alerted when CVE-2025-46813 or the next vulnerability affects your stack