What’s Vulnerable › Vulnerabilities
CVE-2025-46814: FastAPI Guard Remote Header Injection via X-Forwarded-For Manipulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-06 · updated 2026-06-17
- Weakness: CWE-74
Description
FastAPI Guard is a security library for FastAPI that provides middleware to control IPs, log requests, and detect penetration attempts. An HTTP header injection vulnerability has been identified in versions prior to 2.0.0. By manipulating the X-Forwarded-For header, an attacker can potentially inject arbitrary IP addresses into the request. This vulnerability can allow attackers to bypass IP-based access controls, mislead logging systems, and impersonate trusted clients. It is especially impactful when the application relies on the X-Forwarded-For header for IP-based authorization or authentication. Users should upgrade to FastAPI Guard version 2.0.0 to receive a fix.
Affected products
- rennf93 fastapi-guard: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: rennf93 fastapi-guard 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/rennf93/fastapi-guard/commit/0b003fda4c678c1b514e95f319aee88113e9bf4b
- https://github.com/rennf93/fastapi-guard/security/advisories/GHSA-77q8-qmj7-x7pp
Get alerted when CVE-2025-46814 or the next vulnerability affects your stack