What’s Vulnerable › Vulnerabilities
CVE-2025-46817: Lua library commands may lead to integer overflow and potential RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-03 · updated 2026-10-19
- Weakness: CWE-190
Description
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
Affected products
- Redis: before 6.2.20; from 7.0 before 7.2.11; from 7.4.0 before 7.4.6; from 8.0.0 before 8.0.4; from 8.2.0 before 8.2.2 — fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
How to fix
Upgrade to a fixed version: Redis 6.2.20, 7.2.11, 7.4.6, 8.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/fc9abc775e308374f667fdf3e723ef4b7eb0e3ca
- https://github.com/redis/redis/releases/tag/8.2.2
- https://github.com/redis/redis/security/advisories/GHSA-m8fj-85cg-7vhp
Get alerted when CVE-2025-46817 or the next vulnerability affects your stack