What’s Vulnerable › Vulnerabilities
CVE-2025-46818: Redis: Authenticated users can execute LUA scripts as a different user
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-03 · updated 2026-10-19
- Weakness: CWE-94
Description
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user. The problem exists in all versions of Redis with LUA scripting. This issue is fixed in version 8.2.2. A workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing LUA scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.
Affected products
- Redis: before 6.2.20; from 7.0 before 7.2.11; from 7.4.0 before 7.4.6; from 8.0.0 before 8.0.4; from 8.2.0 before 8.2.2 — fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
How to fix
Upgrade to a fixed version: Redis 6.2.20, 7.2.11, 7.4.6, 8.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/45eac0262028c771b6f5307372814b75f49f7a9e
- https://github.com/redis/redis/releases/tag/8.2.2
- https://github.com/redis/redis/security/advisories/GHSA-qrv7-wcrx-q5jp
Get alerted when CVE-2025-46818 or the next vulnerability affects your stack