What’s Vulnerable › Vulnerabilities
CVE-2025-46819: Redis is vulnerable to DoS via specially crafted LUA scripts
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-03 · updated 2026-10-19
- Weakness: CWE-190
Description
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.
Affected products
- Redis: before 6.2.20; from 7.0 before 7.2.11; from 7.4.0 before 7.4.6; from 8.0.0 before 8.0.4; from 8.2.0 before 8.2.2 — fixed in 6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2
How to fix
Upgrade to a fixed version: Redis 6.2.20, 7.2.11, 7.4.6, 8.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/3a1624da2449ac3dbfc4bdaed43adf77a0b7bfba
- https://github.com/redis/redis/releases/tag/8.2.2
- https://github.com/redis/redis/security/advisories/GHSA-4c68-q8q8-3g4f
- https://www.vicarius.io/vsociety/posts/cve-2025-46819-detect-redis-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-46819-mitigate-redis-vulnerability
Get alerted when CVE-2025-46819 or the next vulnerability affects your stack