What’s Vulnerable › Vulnerabilities

CVE-2025-46821: Envoy vulnerable to bypass of RBAC uri_template permission

Description

Envoy is a cloud-native edge/middle/service proxy. Prior to versions 1.34.1, 1.33.3, 1.32.6, and 1.31.8, Envoy's URI template matcher incorrectly excludes the `*` character from a set of valid characters in the URI path. As a result URI path containing the `*` character will not match a URI template expressions. This can result in bypass of RBAC rules when configured using the `uri_template` permissions. This vulnerability is fixed in Envoy versions v1.34.1, v1.33.3, v1.32.6, v1.31.8. As a workaround, configure additional RBAC permissions using `url_path` with `safe_regex` expression.

Affected products

How to fix

Upgrade to a fixed version: envoyproxy envoy 1.31.8, 1.32.6, 1.33.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-46821 or the next vulnerability affects your stack