What’s Vulnerable › Vulnerabilities
CVE-2025-46823: OpenMRS has Vulnerability in FHIR2 Module Privileges
- Severity: high (CVSS 8.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-29 · updated 2026-06-17
- Weakness: CWE-862
Description
openmrs-module-fhir2 provides the FHIR REST API and related services for OpenMRS, an open medical records system. In versions of the FHIR2 module prior to 2.5.0, privileges were not always correctly checked, which means that unauthorized users may have been able to add or edit data they were not supposed to be able to. All implementers should update to FHIR2 2.5.0 or newer as soon as is feasible to receive a patch.
Affected products
- openmrs-module-fhir2: before 2.5.0
References
- https://github.com/openmrs/openmrs-module-fhir2/releases/tag/2.5.0
- https://github.com/openmrs/openmrs-module-fhir2/security/advisories/GHSA-g5vq-w8v2-4x9j
Get alerted when CVE-2025-46823 or the next vulnerability affects your stack