What’s Vulnerable › Vulnerabilities
CVE-2025-46825: Kanboard has stored Cross-site Scripting vulnerability in project name
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Kanboard is project management software that focuses on the Kanban methodology. Versions 1.2.26 through 1.2.44 have a Stored Cross-Site Scripting (XSS) Vulnerability in the `name` parameter of the `http://localhost/?controller=ProjectCreationController&action=create` form. This vulnerability allows attackers to inject malicious scripts into web pages viewed by other users. Note that the default content security policy (CSP) blocks the JavaScript attack, though it can be exploited if an instance is badly configured and the software is vulnerable to CSS injection because of the unsafe-inline on the default CSP. Version 1.2.45 contains a fix for the issue.
Affected products
- kanboard: from 1.2.26 before 1.2.45 — fixed in 1.2.45
How to fix
Upgrade to a fixed version: kanboard 1.2.45. Check the vendor advisory for mitigations.
References
- https://github.com/kanboard/kanboard/blame/v1.2.44/app/Template/project_view/importTasks.php#L11
- https://github.com/kanboard/kanboard/commit/6ebf22eeaae9f8b4abab72e3c18e45a2c4a2a808
- https://github.com/kanboard/kanboard/commit/ac94004ea9fc455dcc5edc8a242d67d1ccd85564
- https://github.com/kanboard/kanboard/security/advisories/GHSA-5wj3-c9v4-pj9v
- https://github.com/kanboard/kanboard/security/advisories/GHSA-5wj3-c9v4-pj9v
Get alerted when CVE-2025-46825 or the next vulnerability affects your stack