What’s Vulnerable › Vulnerabilities
CVE-2025-46835: Git GUI can create and overwrite files for which the user has write permission
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-88
Description
Git GUI allows you to use the Git source control management tools via a GUI. When a user clones an untrusted repository and is tricked into editing a file located in a maliciously named directory in the repository, then Git GUI can create and overwrite files for which the user has write permission. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
Affected products
- j6t git-gui: before 2.43.7; from 2.44.0, < 2.44.4; from 2.45.0, < 2.45.4; from 2.46.0, < 2.46.4; from 2.47.0, < 2.47.3; from 2.48.0, < 2.48.2
References
- https://github.com/j6t/git-gui/compare/dcda716dbc9c90bcac4611bd1076747671ee0906..a437f5bc93330a70b42a230e52f3bd036ca1b1da
- https://github.com/j6t/git-gui/security/advisories/GHSA-xfx7-68v4-v8fg
- http://www.openwall.com/lists/oss-security/2025/07/08/4
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html
Get alerted when CVE-2025-46835 or the next vulnerability affects your stack