What’s Vulnerable › Vulnerabilities
CVE-2025-4691: Free Booking Plugin for Hotels, Restaurants and Car Rentals – eaSYNC Booking <= 1.3.21 - Insecure Direct Object Reference to Sensitive Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-31 · updated 2026-06-17
- Weakness: CWE-639
Description
The Free Booking Plugin for Hotels, Restaurants and Car Rentals – eaSYNC Booking plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.3.21 via the 'view_request_details' due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to view the details of any booking request. The vulnerability was partially patched in versions 1.3.18 and 1.3.21.
Affected products
- syntactics eaSYNC Booking – Hotels, Restaurants & Car Rentals: before 1.3.22 — fixed in 1.3.22
How to fix
Upgrade to a fixed version: syntactics eaSYNC Booking – Hotels, Restaurants & Car Rentals 1.3.22. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/easync-booking/tags/1.3.17/easync.php#L4859
- https://plugins.trac.wordpress.org/changeset/3243634/
- https://plugins.trac.wordpress.org/changeset/3293607/
- https://plugins.trac.wordpress.org/changeset/3300408/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3c9953b3-dd09-4c80-be11-4daf3bbac720?source=cve
Get alerted when CVE-2025-4691 or the next vulnerability affects your stack