What’s Vulnerable › Vulnerabilities
CVE-2025-47109: After Effects | NULL Pointer Dereference (CWE-476)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-476
Description
After Effects versions 25.2, 24.6.6 and earlier are affected by a NULL Pointer Dereference vulnerability that could lead to application denial-of-service. An attacker could exploit this vulnerability to crash the application, causing disruption to services. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: before 24.6.7; from 25.0 before 25.3 — fixed in 24.6.7, 25.3
How to fix
Upgrade to a fixed version: Adobe After Effects 24.6.7, 25.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-47109 or the next vulnerability affects your stack