What’s Vulnerable › Vulnerabilities
CVE-2025-47148: BIG-IP APM and SSL Orchestrator vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-15 · updated 2026-10-08
- Weakness: CWE-404
Description
When the BIG-IP system is configured as both a Security Assertion Markup Language (SAML) service provider (SP) and Identity Provider (IdP), with single logout (SLO) enabled on an access policy, undisclosed requests can cause an increase in memory resource utilization. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 BIG-IP APM: from 15.1.0 before 15.1.10.8; from 16.1.0 before 16.1.6.1; from 17.1.0 before 17.1.3; 17.5.0 — fixed in 15.1.10.8, 16.1.6.1, 17.1.3
- F5 Big-Ip Ssl Orchestrator: from 15.1.0 before 15.1.10.8; from 16.1.0 before 16.1.6.1; from 17.1.0 before 17.1.3; 17.5.0 — fixed in 15.1.10.8, 16.1.6.1, 17.1.3
How to fix
Upgrade to a fixed version: F5 BIG-IP APM 15.1.10.8, 16.1.6.1, 17.1.3; F5 Big-Ip Ssl Orchestrator 15.1.10.8, 16.1.6.1, 17.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-47148 or the next vulnerability affects your stack