What’s Vulnerable › Vulnerabilities
CVE-2025-47241
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-03 · updated 2026-06-17
- Weakness: CWE-647
Description
In browser-use (aka Browser Use) before 0.1.45, URL parsing of allowed_domains is mishandled because userinfo can be placed in the authority component.
Affected products
- browser-use: before 0.1.45 — fixed in 0.1.45
How to fix
Upgrade to a fixed version: browser-use 0.1.45. Check the vendor advisory for mitigations.
References
- https://github.com/browser-use/browser-use/pull/1561
- https://github.com/browser-use/browser-use/releases/tag/0.1.45
- https://github.com/browser-use/browser-use/security/advisories/GHSA-x39x-9qw5-ghrf
Get alerted when CVE-2025-47241 or the next vulnerability affects your stack