What’s Vulnerable › Vulnerabilities
CVE-2025-47273: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-17 · updated 2026-06-17
- Weakness: CWE-22
Description
setuptools is a package that allows users to download, build, install, upgrade, and uninstall Python packages. A path traversal vulnerability in `PackageIndex` is present in setuptools prior to version 78.1.1. An attacker would be allowed to write files to arbitrary locations on the filesystem with the permissions of the process running the Python code, which could escalate to remote code execution depending on the context. Version 78.1.1 fixes the issue.
Affected products
- Debian Linux: 11.0
- pypa setuptools: before 78.1.1 — fixed in 78.1.1
- Pypi Setuptools: before 78.1.1; 0.6b1, 0.6b2, 0.6b3, 0.6b4, 0.6c1, 0.6c10 (+494) — fixed in 78.1.1
How to fix
Upgrade to a fixed version: pypa setuptools 78.1.1; Pypi Setuptools 78.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/pypa/setuptools/blob/6ead555c5fb29bc57fe6105b1bffc163f56fd558/setuptools/package_index.py#L810C1-L825C88
- https://github.com/pypa/setuptools/commit/250a6d17978f9f6ac3ac887091f2d32886fbbb0b
- https://github.com/pypa/setuptools/issues/4946
- https://github.com/pypa/setuptools/security/advisories/GHSA-5rjg-fvgr-3xxf
- https://lists.debian.org/debian-lts-announce/2025/05/msg00035.html
- https://github.com/pypa/setuptools/issues/4946
Get alerted when CVE-2025-47273 or the next vulnerability affects your stack