What’s Vulnerable › Vulnerabilities
CVE-2025-47275: Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-287
Description
Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.
Affected products
- auth0-PHP: from 8.0.0-BETA1, < 8.14.0
References
- https://github.com/auth0/auth0-PHP/commit/52a79480fdb246f59dbc089b81a784ae049bd389
- https://github.com/auth0/auth0-PHP/releases/tag/8.14.0
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-g98g-r7gf-2r25
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-9fwj-9mjf-rhj3
- https://github.com/auth0/symfony/security/advisories/GHSA-9wg9-93h9-j8ch
- https://github.com/auth0/wordpress/security/advisories/GHSA-2f4r-34m4-3w8q
Get alerted when CVE-2025-47275 or the next vulnerability affects your stack