What’s Vulnerable › Vulnerabilities
CVE-2025-47276: Actualizer Uses OpenSSL's "-passwd" Function Which Uses SHA512 Under The Hood Instead of Proper Password Hasher like Yescript/Argon2i
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-328
Description
Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS). Prior to version 1.2.0, Actualizer uses OpenSSL's "-passwd" function, which uses SHA512 instead of a more suitable password hasher like Yescript/Argon2i. All Actualizer users building a full Debian Operating System are affected. Users should upgrade to version 1.2.0 of Actualizer. Existing OS deployment requires manual password changes against the alpha and root accounts. The change will deploy's Debian's yescript overriding the older SHA512 hash created by OpenSSL. As a workaround, users need to reset both `root` and "Alpha" users' passwords.
Affected products
- ChewKeanHo Actualizer: before 1.2.0
References
- https://cheatsheetseries.owasp.org/cheatsheets/Password_Storage_Cheat_Sheet.html
- https://github.com/ChewKeanHo/Actualizer/commit/32c9cc232c856f078f8269fba80ce7562bbff86b
- https://github.com/ChewKeanHo/Actualizer/issues/1
- https://github.com/ChewKeanHo/Actualizer/releases/tag/v1.2.0
- https://github.com/ChewKeanHo/Actualizer/security/advisories/GHSA-v626-chv9-v9qr
- https://github.com/openssl/openssl/issues/19340
- https://www.reddit.com/r/debian/comments/1kknzqi/actualizer_v110_upgraded
Get alerted when CVE-2025-47276 or the next vulnerability affects your stack