What’s Vulnerable › Vulnerabilities

CVE-2025-47279: undici Denial of Service attack via bad certificate data

Description

Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.

Affected products

How to fix

Upgrade to a fixed version: Npm Undici 5.29.0, 6.21.2, 7.5.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-47279 or the next vulnerability affects your stack