What’s Vulnerable › Vulnerabilities
CVE-2025-47283: Bypassing project secret validation can lead to privilege escalation
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-20
Description
Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. `gardener/gardener` (`gardenlet`) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.
Affected products
- gardener: before 1.116.4; from 1.117.0 before 1.117.5; from 1.118.0 before 1.118.2 — fixed in 1.116.4, 1.117.5, 1.118.2
How to fix
Upgrade to a fixed version: gardener 1.116.4, 1.117.5, 1.118.2. Check the vendor advisory for mitigations.
References
- https://github.com/gardener/gardener/commit/924b1575aae052bcda5a51fac8594d38fa3c41b0
- https://github.com/gardener/gardener/commit/b89cf2cd5067e82f364063d5241af73650a6e11d
- https://github.com/gardener/gardener/commit/bbd19b1dd3a31843d7b820172d37f75298dfaf8b
- https://github.com/gardener/gardener/commit/cf4e9887d83902216b85609caf563f7a9dd2de00
- https://github.com/gardener/gardener/security/advisories/GHSA-3hw7-qj9h-r835
Get alerted when CVE-2025-47283 or the next vulnerability affects your stack