What’s Vulnerable › Vulnerabilities
CVE-2025-47287: Tornado vulnerable to excessive logging caused by malformed multipart form data
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-770
Description
Tornado is a Python web framework and asynchronous networking library. When Tornado's ``multipart/form-data`` parser encounters certain errors, it logs a warning but continues trying to parse the remainder of the data. This allows remote attackers to generate an extremely high volume of logs, constituting a DoS attack. This DoS is compounded by the fact that the logging subsystem is synchronous. All versions of Tornado prior to 6.5.0 are affected. The vulnerable parser is enabled by default. Upgrade to Tornado version 6.50 to receive a patch. As a workaround, risk can be mitigated by blocking `Content-Type: multipart/form-data` in a proxy.
Affected products
- Debian Linux: 11.0
- tornadoweb tornado: before 6.5.0 — fixed in 6.5.0
- Pypi Tornado: before 6.5; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+69) — fixed in 6.5
How to fix
Upgrade to a fixed version: tornadoweb tornado 6.5.0; Pypi Tornado 6.5. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/commit/b39b892bf78fe8fea01dd45199aa88307e7162f3
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-7cx3-6m66-7c5m
- https://lists.debian.org/debian-lts-announce/2025/05/msg00038.html
Get alerted when CVE-2025-47287 or the next vulnerability affects your stack