What’s Vulnerable › Vulnerabilities
CVE-2025-47288: Discourse Policy plugin private group members visible
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-29 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse Policy plugin gives the ability to confirm users have seen or done something. Prior to version 0.1.1, if there was a policy posted to a public topic that was tied to a private group then the group members could be shown to non-group members. This issue has been patched in version 0.1.1. A workaround involves moving any policy topics with private groups to restricted categories.
Affected products
- discourse-policy: before 0.1.1
References
- https://github.com/discourse/discourse-policy/commit/6b4390fe486408cc86ccea6b091406cfac6c5b8f
- https://github.com/discourse/discourse-policy/security/advisories/GHSA-jc5r-rm2j-mh4x
Get alerted when CVE-2025-47288 or the next vulnerability affects your stack