What’s Vulnerable › Vulnerabilities
CVE-2025-47291: containerd CRI plugin: Incorrect cgroup hierarchy assignment for containers running in usernamespaced Kubernetes pods.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-21 · updated 2026-06-17
- Weakness: CWE-266
Description
containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.
Affected products
- containerd: from 2.0.1 before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: containerd 2.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-47291 or the next vulnerability affects your stack