What’s Vulnerable › Vulnerabilities
CVE-2025-47410: Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-18 · updated 2026-10-08
- Weakness: CWE-352
Description
Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Geode: from 1.10.0 before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Geode 1.15.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/k88tv3rhl4ymsvt4h6qsv7sq10q5prrt
- http://www.openwall.com/lists/oss-security/2025/10/17/2
Get alerted when CVE-2025-47410 or the next vulnerability affects your stack