What’s Vulnerable › Vulnerabilities
CVE-2025-47411: Apache StreamPipes: Leverage of User ID for Privilege Escalation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-01 · updated 2026-10-07
- Weakness: CWE-269
Description
A user with a legitimate non-administrator account can exploit a vulnerability in the user ID creation mechanism in Apache StreamPipes that allows them to swap the username of an existing user with that of an administrator. This vulnerability allows an attacker to gain administrative control over the application by manipulating JWT tokens, which can lead to data tampering, unauthorized access and other security issues. This issue affects Apache StreamPipes: through 0.97.0. Users are recommended to upgrade to version 0.98.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache StreamPipes: from 0.69.0 before 0.98.0 — fixed in 0.98.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache StreamPipes 0.98.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/lngko4ht2ok3o0rk9h0clgm4kb0lmt36
- http://www.openwall.com/lists/oss-security/2025/12/29/14
Get alerted when CVE-2025-47411 or the next vulnerability affects your stack