What’s Vulnerable › Vulnerabilities
CVE-2025-47479: WordPress WP Compress plugin <= 6.30.30 - Broken Authentication Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-06-17
- Weakness: CWE-1390
Description
Weak Authentication vulnerability in AresIT WP Compress wp-compress-image-optimizer allows Authentication Abuse.This issue affects WP Compress: from n/a through <= 6.30.30.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.30.31 — fixed in 6.30.31
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.30.31. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-47479 or the next vulnerability affects your stack