What’s Vulnerable › Vulnerabilities
CVE-2025-4759
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-16 · updated 2026-06-17
- Weakness: CWE-179
Description
Versions of the package lockfile-lint-api before 5.9.2 are vulnerable to Incorrect Behavior Order: Early Validation via the resolved attribute of the package URL validation which can be bypassed by extending the package name allowing an attacker to install other npm packages than the intended one.
Affected products
- lockfile-lint-api: before 5.9.2 — fixed in 5.9.2
How to fix
Upgrade to a fixed version: lockfile-lint-api 5.9.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xavier59/881aef04940970dc3e738dcbff64151f
- https://github.com/lirantal/lockfile-lint/blob/89b5cad028df4d77bab2b73ac93bc61e392668ab/packages/lockfile-lint-api/src/validators/ValidatePackageNames.js%23L51-L63
- https://github.com/lirantal/lockfile-lint/commit/9e5305bd3e4f0c6acc0d23ec43eac2bd5303b4ca
- https://github.com/lirantal/lockfile-lint/pull/204
- https://security.snyk.io/vuln/SNYK-JS-LOCKFILELINTAPI-10169587
Get alerted when CVE-2025-4759 or the next vulnerability affects your stack