What’s Vulnerable › Vulnerabilities
CVE-2025-47701: Restrict route by IP - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-047
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Restrict route by IP allows Cross Site Request Forgery.This issue affects Restrict route by IP: from 0.0.0 before 1.3.0.
Affected products
- Drupal Restrict route by IP: from 1.0.0 before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Drupal Restrict route by IP 1.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-47701 or the next vulnerability affects your stack