What’s Vulnerable › Vulnerabilities
CVE-2025-47708: Enterprise MFA - TFA for Drupal - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-054
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Enterprise MFA - TFA for Drupal allows Cross Site Request Forgery.This issue affects Enterprise MFA - TFA for Drupal: from 0.0.0 before 4.7.0, from 5.0.0 before 5.2.0.
Affected products
- Miniorange 2Fa: from 5.0.0 before 5.2.0; from 7.x-2.16 before 8.x-4.7 — fixed in 5.2.0, 8.x-4.7
How to fix
Upgrade to a fixed version: Miniorange 2Fa 5.2.0, 8.x-4.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-47708 or the next vulnerability affects your stack