What’s Vulnerable › Vulnerabilities
CVE-2025-47771: PowSyBl Core allows deserialization of untrusted SparseMatrix data
- Severity: high (CVSS 8.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-20 · updated 2026-06-17
- Weakness: CWE-502
Description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. In versions 6.3.0 to 6.7.1, there is a deserialization issue in the read method of the SparseMatrix class that can lead to a wide range of privilege escalations depending on the circumstances. This method takes in an InputStream and returns a SparseMatrix object. This issue has been patched in com.powsybl:powsybl-math: 6.7.2. A workaround for this issue involves not using SparseMatrix deserialization (SparseMatrix.read(...) methods).
Affected products
- powsybl-core: from 6.3.0, < 6.7.2
References
- https://github.com/powsybl/powsybl-core/commit/8ed16ce41683c4aef5f6aa1dd5ae8642aa5ed2bd
- https://github.com/powsybl/powsybl-core/releases/tag/v6.7.2
- https://github.com/powsybl/powsybl-core/security/advisories/GHSA-f5cx-h789-j959
Get alerted when CVE-2025-47771 or the next vulnerability affects your stack