What’s Vulnerable › Vulnerabilities
CVE-2025-47777: 5ire Client Vulnerable to Cross-Site Scripting (XSS) and Remote Code Execution (RCE)
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-20
Description
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Versions prior to 0.11.1 are vulnerable to stored cross-site scripting in chatbot responses due to insufficient sanitization. This, in turn, can lead to Remote Code Execution (RCE) via unsafe Electron protocol handling and exposed Electron APIs. All users of 5ire client versions prior to patched releases, particularly those interacting with untrusted chatbots or pasting external content, are affected. Version 0.11.1 contains a patch for the issue.
Affected products
- nanbingxyz 5ire: before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: nanbingxyz 5ire 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/nanbingxyz/5ire/commit/56601e012095194a4be0d4cb6da6b5b3cb53dea8
- https://github.com/nanbingxyz/5ire/security/advisories/GHSA-mr8w-mmvv-6hq8
- https://positive.security/blog/url-open-rce
- https://shabarkin.notion.site/1-click-RCE-in-Electron-Applications-501c2e96e7934610979cd3c72e844a22
- https://www.electronjs.org/docs/latest/tutorial/security
- https://www.youtube.com/watch?v=ROFYhS9E9eU
Get alerted when CVE-2025-47777 or the next vulnerability affects your stack