What’s Vulnerable › Vulnerabilities
CVE-2025-47780: cli_permissions.conf: deny option does not work for disallowing shell commands
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.26.2, 20.14.1, 21.9.1, and 22.4.1 of Asterisk and versions 18.9-cert14 and 20.7-cert5 of certified-asterisk, trying to disallow shell commands to be run via the Asterisk command line interface (CLI) by configuring `cli_permissions.conf` (e.g. with the config line `deny=!*`) does not work which could lead to a security risk. If an administrator running an Asterisk instance relies on the `cli_permissions.conf` file to work and expects it to deny all attempts to execute shell commands, then this could lead to a security vulnerability. Versions 18.26.2, 20.14.1, 21.9.1, and 22.4.1 of Asterisk and versions 18.9-cert14 and 20.7-cert5 of certified-asterisk fix the issue.
Affected products
- asterisk: before 18.26.2; from 20.0.0 before 20.14.1; from 21.0.0 before 21.9.1; from 22.0.0 before 22.4.1 — fixed in 18.26.2, 20.14.1, 21.9.1, 22.4.1
- Sangoma Certified Asterisk: before 18.9; 18.9, 18.9-cert1, 18.9-cert1-rc1, 18.9-cert10, 18.9-cert11, 18.9-cert12 (+17) — fixed in 18.9
How to fix
Upgrade to a fixed version: asterisk 18.26.2, 20.14.1, 21.9.1, 22.4.1; Sangoma Certified Asterisk 18.9. Check the vendor advisory for mitigations.
References
- https://github.com/asterisk/asterisk/security/advisories/GHSA-c7p6-7mvq-8jq2
- https://lists.debian.org/debian-lts-announce/2025/06/msg00003.html
Get alerted when CVE-2025-47780 or the next vulnerability affects your stack