What’s Vulnerable › Vulnerabilities
CVE-2025-47905
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-444
Description
Varnish Cache before 7.6.3 and 7.7 before 7.7.1, and Varnish Enterprise before 6.0.13r14, allow client-side desync via HTTP/1 requests, because the product incorrectly permits CRLF to be skipped to delimit chunk boundaries.
Affected products
- varnish-software Varnish Cache: before 6.0.14 LTS; from 7.0.0 before 7.6.3; from 7.7.0 before 7.7.1 — fixed in 6.0.14 LTS, 7.6.3, 7.7.1
How to fix
Upgrade to a fixed version: varnish-software Varnish Cache 6.0.14 LTS, 7.6.3, 7.7.1. Check the vendor advisory for mitigations.
References
- https://varnish-cache.org/security/VSV00016.html
- http://www.openwall.com/lists/oss-security/2025/05/15/2
- https://lists.debian.org/debian-lts-announce/2025/05/msg00040.html
Get alerted when CVE-2025-47905 or the next vulnerability affects your stack