What’s Vulnerable › Vulnerabilities
CVE-2025-47914: Malformed constraint may cause denial of service in golang.org/x/crypto/ssh/agent
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-125
Description
SSH Agent servers do not validate the size of messages when processing new identity requests, which may cause the program to panic if the message is malformed due to an out of bounds read.
Affected products
- golang.org/x/crypto/ssh: before 0.45.0 — fixed in 0.45.0
- Golang.Org/X/Crypto: before 0.45.0 — fixed in 0.45.0
How to fix
Upgrade to a fixed version: golang.org/x/crypto/ssh 0.45.0; Golang.Org/X/Crypto 0.45.0. Check the vendor advisory for mitigations.
References
- https://go.dev/cl/721960
- https://go.dev/issue/76364
- https://groups.google.com/g/golang-announce/c/w-oX3UxNcZA
- https://pkg.go.dev/vuln/GO-2025-4135
Get alerted when CVE-2025-47914 or the next vulnerability affects your stack