What’s Vulnerable › Vulnerabilities
CVE-2025-47931: LibreNMS stored Cross-site Scripting vulnerability in poller group name
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-17 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is PHP/MySQL/SNMP based network monitoring software. LibreNMS v25.4.0 and prior suffers from a Stored Cross-Site Scripting (XSS) Vulnerability in the `group name` parameter of the `http://localhost/poller/groups` form. This vulnerability allows attackers to inject malicious scripts into web pages viewed by other users. LibreNMS v25.5.0 contains a patch for the issue.
Affected products
- librenms: before 25.5.0 — fixed in 25.5.0
How to fix
Upgrade to a fixed version: librenms 25.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/blob/25.4.0/includes/html/pages/addhost.inc.php#L284
- https://github.com/librenms/librenms/commit/88fe1a7abdb500d9a2d4c45f9872df54c9ff8062
- https://github.com/librenms/librenms/pull/17603
- https://github.com/librenms/librenms/security/advisories/GHSA-hxw5-9cc5-cmw5
Get alerted when CVE-2025-47931 or the next vulnerability affects your stack