What’s Vulnerable › Vulnerabilities
CVE-2025-47935: Multer vulnerable to Denial of Service via memory leaks from unclosed streams
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-401
Description
Multer is a node.js middleware for handling `multipart/form-data`. Versions prior to 2.0.0 are vulnerable to a resource exhaustion and memory leak issue due to improper stream handling. When the HTTP request stream emits an error, the internal `busboy` stream is not closed, violating Node.js stream safety guidance. This leads to unclosed streams accumulating over time, consuming memory and file descriptors. Under sustained or repeated failure conditions, this can result in denial of service, requiring manual server restarts to recover. All users of Multer handling file uploads are potentially impacted. Users should upgrade to 2.0.0 to receive a patch. No known workarounds are available.
Affected products
- multer: before 2.0.0
References
- https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665
- https://github.com/expressjs/multer/pull/1120
- https://github.com/expressjs/multer/security/advisories/GHSA-44fp-w29j-9vj5
Get alerted when CVE-2025-47935 or the next vulnerability affects your stack