What’s Vulnerable › Vulnerabilities
CVE-2025-47940: TYPO3 CMS Vulnerable to Privilege Escalation to System Maintainer
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-283
Description
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
Affected products
- typo3: from 10.4.0 before 10.4.50; from 11.0.0 before 11.5.44; from 12.0.0 before 12.4.31; from 13.0.0 before 13.4.12 — fixed in 10.4.50, 11.5.44, 12.4.31, 13.4.12
How to fix
Upgrade to a fixed version: typo3 10.4.50, 11.5.44, 12.4.31, 13.4.12. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-6frx-j292-c844
- https://typo3.org/security/advisory/typo3-core-sa-2025-016
Get alerted when CVE-2025-47940 or the next vulnerability affects your stack