What’s Vulnerable › Vulnerabilities
CVE-2025-47943: Gogs stored XSS in PDF renderer
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.
Affected products
- gogs: through 0.14.0+dev
References
- https://github.com/gogs/gogs/commit/110117b2e5e5baa4809c819bec701e929d2d8d40
- https://github.com/gogs/gogs/releases/tag/v0.13.3
- https://github.com/gogs/gogs/security/advisories/GHSA-xh32-cx6c-cp4v
- https://www.hacktivesecurity.com/blog/2025/07/15/cve-2025-47943-stored-xss-in-gogs-via-pdf
- https://github.com/gogs/gogs/security/advisories/GHSA-xh32-cx6c-cp4v
Get alerted when CVE-2025-47943 or the next vulnerability affects your stack