What’s Vulnerable › Vulnerabilities
CVE-2025-47944: Multer vulnerable to Denial of Service from maliciously crafted requests
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-248
Description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
Affected products
- multer: from 1.4.4-lts.1, <2.0.0
References
- https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665
- https://github.com/expressjs/multer/issues/1176
- https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h
Get alerted when CVE-2025-47944 or the next vulnerability affects your stack