What’s Vulnerable › Vulnerabilities
CVE-2025-47947: ModSecurity Has Possible DoS Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-21 · updated 2026-06-17
- Weakness: CWE-1050
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions up to and including 2.9.8 are vulnerable to denial of service in one special case (in stable released versions): when the payload's content type is `application/json`, and there is at least one rule which does a `sanitiseMatchedBytes` action. A patch is available at pull request 3389 and expected to be part of version 2.9.9. No known workarounds are available.
Affected products
- Trustwave Modsecurity: before 2.9.9 — fixed in 2.9.9
How to fix
Upgrade to a fixed version: Trustwave Modsecurity 2.9.9. Check the vendor advisory for mitigations.
References
- https://github.com/owasp-modsecurity/ModSecurity/pull/3389
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-859r-vvv8-rm8r
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-859r-vvv8-rm8r
Get alerted when CVE-2025-47947 or the next vulnerability affects your stack