What’s Vulnerable › Vulnerabilities
CVE-2025-4799: WP-DownloadManager <= 1.68.10 - Authenticated (Administrator+) Arbitrary File Deletion
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-11 · updated 2026-06-17
- Weakness: CWE-36
Description
The WP-DownloadManager plugin for WordPress is vulnerable to arbitrary file deletion due to lack of restriction on the directory a file can be deleted from in all versions up to, and including, 1.68.10. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). This vulnerability can be paired with CVE-2025-4798 to delete any file within the WordPress root directory.
Affected products
- gamerz WP-DownloadManager: before 1.68.11 — fixed in 1.68.11
How to fix
Upgrade to a fixed version: gamerz WP-DownloadManager 1.68.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-downloadmanager/trunk/download-manager.php#L215
- https://plugins.trac.wordpress.org/browser/wp-downloadmanager/trunk/download-options.php#L16
- https://plugins.trac.wordpress.org/browser/wp-downloadmanager/trunk/download-options.php#L42
- https://plugins.trac.wordpress.org/changeset/3294467/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f9d9e485-171f-4e36-943d-397d540e31f4?source=cve
Get alerted when CVE-2025-4799 or the next vulnerability affects your stack