What’s Vulnerable › Vulnerabilities
CVE-2025-48024
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-497
Description
In BlueWave Checkmate before 2.1, an authenticated regular user can access sensitive application secrets via the /api/v1/settings endpoint.
Affected products
- BlueWave Checkmate: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: BlueWave Checkmate 2.1. Check the vendor advisory for mitigations.
References
- https://github.com/bluewave-labs/Checkmate/commit/36d78a9aa4ed607ca1bd2b5fdaca5a3927b2d287
- https://github.com/bluewave-labs/Checkmate/commit/7a855ef47adf2265121c236097059c7c6555fd7c
- https://github.com/bluewave-labs/Checkmate/commit/91c2f7f0d5106bdfd4a0ff2c14b7e44acc3baee6
- https://github.com/bluewave-labs/Checkmate/pull/2227
- https://github.com/bluewave-labs/Checkmate/security/advisories/GHSA-jjmg-cjr4-439m
Get alerted when CVE-2025-48024 or the next vulnerability affects your stack