What’s Vulnerable › Vulnerabilities
CVE-2025-4804: WatchGuard Firebox Stored Cross-Site-Scripting (XSS) Vulnerability in Hotpot Configuration
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-16 · updated 2026-08-08
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WatchGuard Fireware OS allows Stored XSS via the spamBlocker module. This vulnerability requires an authenticated administrator session to a locally managed Firebox.
Affected products
- WatchGuard Fireware OS: from 12.0 before 12.11.2; from 12.5 before 12.5.13 — fixed in 12.11.2, 12.5.13
How to fix
Upgrade to a fixed version: WatchGuard Fireware OS 12.11.2, 12.5.13. Check the vendor advisory for mitigations.
References
- https://psirt.watchguard.com/CVE-2025-4804
- https://www.watchguard.com/wgrd-psirt/advisory/wgsa-2025-00006
Get alerted when CVE-2025-4804 or the next vulnerability affects your stack