What’s Vulnerable › Vulnerabilities
CVE-2025-48042: Before action hooks may execute in certain scenarios despite a request being forbidden
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-07 · updated 2026-10-19
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in ash-project ash allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects ash: from 0.1.1 before 3.5.39.
Affected products
- ash-project ash: from 0.1.1 before 3.5.39 — fixed in 3.5.39
How to fix
Upgrade to a fixed version: ash-project ash 3.5.39. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2025-48042.html
- https://github.com/ash-project/ash/commit/4c41344126b0aba09ec3085517000f8aefec299e
- https://github.com/ash-project/ash/commit/5d1b6a5d00771fd468a509778637527b5218be9a
- https://github.com/ash-project/ash/security/advisories/GHSA-jj4j-x5ww-cwh9
- https://osv.dev/vulnerability/EEF-CVE-2025-48042
Get alerted when CVE-2025-48042 or the next vulnerability affects your stack