What’s Vulnerable › Vulnerabilities
CVE-2025-48043: Bypass and runtime policies that can never pass may be incorrectly applied in filter authorization
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-10 · updated 2026-10-19
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in ash-project ash allows Authentication Bypass. This issue affects ash: from 0.1.1 before 3.6.2.
Affected products
- ash-project ash: from 0.1.1 before 3.6.2 — fixed in 3.6.2
How to fix
Upgrade to a fixed version: ash-project ash 3.6.2. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2025-48043.html
- https://github.com/ash-project/ash/commit/4c41344126b0aba09ec3085517000f8aefec299e
- https://github.com/ash-project/ash/commit/66d81300065b970da0d2f4528354835d2418c7ae
- https://github.com/ash-project/ash/security/advisories/GHSA-7r7f-9xpj-jmr7
- https://osv.dev/vulnerability/EEF-CVE-2025-48043
Get alerted when CVE-2025-48043 or the next vulnerability affects your stack