What’s Vulnerable › Vulnerabilities
CVE-2025-48044: Authorization bypass when bypass policy condition evaluates to true
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-17 · updated 2026-10-19
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in ash-project ash allows Authentication Bypass. This issue affects ash: from 3.6.3 before 3.7.1.
Affected products
- ash-project ash: from 3.6.3 before 3.7.1 — fixed in 3.7.1
How to fix
Upgrade to a fixed version: ash-project ash 3.7.1. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2025-48044.html
- https://github.com/ash-project/ash/commit/79749c2685ea031ebb2de8cf60cc5edced6a8dd0
- https://github.com/ash-project/ash/commit/8b83efa225f657bfc3656ad8ee8485f9b2de923d
- https://github.com/ash-project/ash/security/advisories/GHSA-pcxq-fjp3-r752
- https://osv.dev/vulnerability/EEF-CVE-2025-48044
- https://github.com/ash-project/ash/security/advisories/GHSA-pcxq-fjp3-r752
Get alerted when CVE-2025-48044 or the next vulnerability affects your stack