What’s Vulnerable › Vulnerabilities
CVE-2025-48053: Discourse vulnerable to DoS via large URL payload in PM to a bot
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, sending a malicious URL in a PM to a bot user can cause a reduced the availability of a Discourse instance. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. No known workarounds are available.
Affected products
- discourse: before 3.4.4; before 3.5.0; 3.5.0-beta1, 3.5.0-beta2, 3.5.0-beta3, 3.5.0-beta4 — fixed in 3.4.4, 3.5.0
How to fix
Upgrade to a fixed version: discourse 3.4.4, 3.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48053 or the next vulnerability affects your stack