What’s Vulnerable › Vulnerabilities
CVE-2025-48056: Hubble CLI vulnerable to character injection
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-74
Description
Hubble is a fully distributed networking and security observability platform for cloud native workloads. Prior to version 1.17.2, a network attacker could inject malicious control characters into Hubble CLI terminal output, potentially leading to loss of integrity and manipulation of the output. This could be leveraged to conceal log entries, rewrite output, or even make the terminal temporarily unusable. Exploitation of this attack would require the victim to be monitoring Kafka traffic using Layer 7 Protocol Visibility at the time of the attack. The issue is patched in Hubble CLI v1.17.2. Hubble CLI users who are unable to upgrade can direct their Hubble flows to a log file and inspect the output within a text editor.
Affected products
- cilium hubble: before 1.17.2
References
- https://github.com/cilium/cilium/pull/37401
- https://github.com/cilium/hubble/security/advisories/GHSA-274q-79q9-52j7
Get alerted when CVE-2025-48056 or the next vulnerability affects your stack