What’s Vulnerable › Vulnerabilities
CVE-2025-48058: PowSyBl Core contains Polynomial REDoS’es
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-20 · updated 2026-06-17
- Weakness: CWE-1333
Description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, there is a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the PowSyBl's DataSource mechanism. If successfully exploited, a malicious actor can cause significant CPU consumption due to regex backtracking — even with polynomial patterns. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.
Affected products
- powsybl-core: before 6.7.2
References
- https://github.com/powsybl/powsybl-core/commit/72f79dec6d4292f892fbddd68a19c67935c7d81f
- https://github.com/powsybl/powsybl-core/releases/tag/v6.7.2
- https://github.com/powsybl/powsybl-core/security/advisories/GHSA-rqpx-f6rc-7hm5
Get alerted when CVE-2025-48058 or the next vulnerability affects your stack