What’s Vulnerable › Vulnerabilities
CVE-2025-48068: Information exposure in Next.js dev server due to lack of origin verification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-1385
Description
Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.
Affected products
- Next.js: from 13.0.0 before 14.2.30; from 15.0.0 before 15.2.2 — fixed in 14.2.30, 15.2.2
- Npm Next: from 15.0.0 before 15.2.2; from 13.0 before 14.2.30 — fixed in 15.2.2, 14.2.30
How to fix
Upgrade to a fixed version: Next.js 14.2.30, 15.2.2; Npm Next 15.2.2, 14.2.30. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-3h52-269p-cp9r
- https://vercel.com/changelog/cve-2025-48068
Get alerted when CVE-2025-48068 or the next vulnerability affects your stack