What’s Vulnerable › Vulnerabilities
CVE-2025-48267: WordPress WP Pipes plugin <= 1.4.2 - Arbitrary File Deletion Vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in ThimPress WP Pipes allows Path Traversal. This issue affects WP Pipes: from n/a through 1.4.2.
Affected products
- ThimPress WP Pipes: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: ThimPress WP Pipes 1.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48267 or the next vulnerability affects your stack